<-- back

[SOLVED] Enabling samba-4.14.2 Topic Updates May Result in File Conflicts

If you encounter the following error when enabling the samba-4.14.2 topic (which fixes media playback over smb with mpv):

Unpacking perl-parse-yapp (1.21) ...
dpkg: error processing archive /tmp/apt-dpkg-install-PnhW7B/3-perl-parse-yapp_1.21_all.deb (--unpack):
 trying to overwrite '/usr/share/perl5/vendor_perl/Parse/Yapp/Driver.pm', which is also in package samba 4.10.17-1

You may execute apt install -f to complete the installation, we will release a fix as soon as possible.


2021-04-22 Update

The fix has already been merged into the stable repository.


— Jack Wu, Mingcong Bai